🔌 8 Jahre Plugins für JTL Shops! 🔌

Fragen und Antworten

Zu welchem Thema haben Sie eine Frage?


Plugininstallation /-updates
  • Sollten Sie unsere Plugins über den JTL Extension Store installieren wollen oder installiert haben, dann beachten Sie bitte folgende Anleitung: https://guide.jtl-software.de/jtl-shop/shop-erweitern/extension-store/

    Unsere Plugins können in wenigen Schritte einfach installiert und geupdated werden:

    1. Laden Sie auf der Pluginseite im Reiter "Plugin downloaden" die richtige PHP Version herunter
    2. Speichern Sie das .zip auf Ihrem Rechner, dort, wo Sie es leicht wiederfinden
    3. Navigieren Sie in der Shop Administration zur Pluginverwaltung und laden Sie das .zip im Reiter "Upload" hoch.
    4. Rufen Sie die Pluginverwaltung erneut auf.
    5. Sie finden das Plugin dann unter "Verfügbar" und können es dort installieren. Sollten Sie das Plugin bereits installiert haben, dann finden Sie dort, wo es aufgeführt ist ("Aktiviert", "Deaktiviert" oder "Probleme") die Information über das Update, sofern eins vorhanden ist.
    6. Bei neuer Installation finden Sie das Plugin unter "Probleme" und müssen dort Ihren Lizenzschlüssel eintragen. Sollten Sie noch keinen Lizenzschlüssel haben, so aktivieren Sie das Plugin mit dem Lizenzschlüssel "demo".
    7. Das Plugin befindet sich nun im Reiter "Aktiviert" und es können die Einstellungen vorgenommen werden.
  • Ein direktes Upgrade eines JTL Shop 4 Plugins zu einem JTL Shop 5 Plugin ist leider nicht möglich. Folgen Sie diesen Schritten für eine reibungsloses Upgrade:

    1. Merken Sie sich VOR dem Upgrade des JTL Shop 4 zum JTL Shop 5 die Einstellungen des Plugins. Machen Sie dazu Screenshots oder lassen Sie es einfach einem anderen Fenster oder Tab geöffnet.
    2. Deinstallieren Sie das Plugin im JTL Shop 4 und löschen Sie es direkt vom Server. Das Löschen können Sie aber auch später im JTL Shop 5 machen, da gibt es eine entsprechende Funktion im Plugin-Manager unter "Vorhandene" - aber bevor Sie das JTL Shop 5 Plugin installieren!
    3. Installieren Sie nun das JTL Shop 5 Plugin (entweder nach Download hier auf  NETZdinge.de über den Plugin-Manager oder nach Kauf im JTL Extension Store über "Maine Käufe".
    4. Nur bei Installation über den Plugin-Manager: tragen Sie Ihren Lizenzschlüssel ein, das Plugin befindet sich im Plugin-Manager unter Probleme. Wenn Ihre Subscription abgelaufen ist, müssen Sie zuvor eine Verlängerung oder einen Erstkauf erwerben.
    5. Übertragen Sie nun die Einstellungen aus den Screenshots oder dem noch geöffneten JTL Shop 4 Tab. Einzelne Optionen können sich geändert haben. Zum Beispiel ist ein Dropdownfeldn nun eine Checkbox. Speichern Sie jeden Tab einzeln ab, sonst gehen Einstellungen verloren.
    6. Wenn Sie fertig sind, können Sie das Fenster mit den JTL Shop 4 Einstellungen schließen.
  • Ja, der der "ionCube Loader" wird bei allen unseren Plugins benötigt. Je nach Ihrer genutzten PHP Version muss der "ionCube Loader" auf Ihrem Shop Server aktuell sein bzw. eine bestimmte Version haben. Wenn Sie sich unsicher sind, fragen Sie Ihren Hosting Anbieter, ob der "ionCube Loader" in der aktuellen Version installiert ist. Bei Anbietern wie "ionos" oder "Strato" ist das in der Regel nicht der Fall. Anbieter wie "All-Inkl" und auch das JTL Hosting haben den "ionCube Laoder" in der Regel installiert. Oftmals lässt sich der "ionCube Loader" in den Servereinstellungen des Anbieters leicht aktivieren, so wie bei "Hetzner" zu Beispiel.
Lizenz / Subscription
  • Ja, das ist kein Problem, sofern eine gültige Subscription vorhanden ist. Das gilt aber nur für eine bei NETZdinge.de gekaufte Lizenz bzw. bei NETZdinge.de verlängerte Subscription. Jedoch kann eine im JTL Extension Store gekaufte JTL Shop 4 Lizenz hier auf NETZdinge.de verlängert werden (man verlässt dann aber den Subscriptionszyklus im JTL Extension Store).
  • Wenn Sie eine Plugin-Lizenz erwerben, dann ist diese dauerhaft gültig. Sie können Ihr Plugin also dauerhaft in der erworbenen Version in Ihrem JTL Shop, der Version für die die Plugin-Version geeignet ist, nutzen. Für den späteren Erhalt von höheren Versionen des Plugins benötigen Sie immer eine gültige Subscription. Mit dem Erwerb einer Lizenz erhalten Sie automatisch 12 Monate Subscription dazu und können in dieser Zeit höhere Versionen des Plugins installieren und nutzen. Ausserhalb einer gültigen Subscription können Sie das entsprechende Plugin nicht mehr in einer höhreren Version installieren, das Plugin würde sich im JTL Shop selbst abschalten. Eine Information darüber erhalten Sie in den jeweiligen Plugineinstellungen im Reiter "Lizenz" oder "Status".

    Es gelten unsre Lizenzbedingungen!

  • Das ist leider nicht möglich. Wenn Sie ein Plugin über den JTL Extension Store beziehen wollen, dann müssen Sie es dort erwerben.

    Sie können aber natürlich eine neue Lizenz im JTL Extension Store kaufen statt die Subscription für eine vorhandene Lizenz auf NETZdinge.de zu verlängern.

    Wenn Sie das machen wollen, muss das Plugin aber dann in Ihrem Shop komplett deinstaliert, vom Server gelöscht (entsprechende Option beim Deinstallieren nutzen) und über "Meine Käufe" neu installiert werden, Merken Sie sich vorab die Einstellungen (lassen Sie am besten die Plugin- und Plugin-Spracheinstellungen in einem anderen Tab geöffnet oder machen Sie Screenshots)